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Abstract-Although wired charging is a common and well- established method for charging electric vehicles (EVs), it 
has some disadvantages like convenience, wear and tear, safety, compatability etc. Wireless charging offers several 
advantages for EV owners, including convenience, safety, efficiency, durability, and flexibility. As the technology 
continues to improve and become more widely available, it is likely that more and more drivers will choose wireless 
charging as their preferred method of charging their EVs.IOT-based control for vehicles offers several advantages, 
including real-time monitoring, remote control, data analysis, integration with other systems, and predictive 
maintenance. As the technology continues to evolve and become more widely adopted. 
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I.INTRODUCTION 

Today, the Electric vehicles are becoming popular as fuel prices are becoming more expensive day by day. 
Because of this scenario, many vehicle manufacturers are looking for alternatives energy sources other than gas. 
The use of electricity sources can improve the environment as there is less pollution.Wireless charging 
technology is one such solution that promises to revolutionize the way we charge our vehicles. With the ability 
to charge electric vehicles without the need for cumbersome cables and plugs, wireless charging offers a more 
convenient and user-friendly experience for EV owners.The integration of a battery management system ensures 
that the charging process is optimized for the health and longevity of the EV battery, maximizing its 
performance and lifespan. This is crucial for the overall sustainability of electric transportation and reducing the 
environmental impact of our transportation systems.In addition The Internet of Things (IOT) is transforming the 
way we interact with the world around us, and the transportation industry is no exception. IOT-based control for 
vehicles is a rapidly evolving field that holds great promise for enhancing the safety, efficiency, and 
convenience of modern transportation.This project represents an exciting opportunity to explore the potential of 
IOT technology in the transportation industry and to develop innovative solutions that will shape the future of 
how we move around. Also this project aims to explore the potential of wireless charging for electric vehicles, 
with a focus on developing a battery management system that can enhance the efficiency and effectiveness of the 
charging process. 
Related work: 
There are several types of existing charging systems for electric vehicles, including: 

1. Level 1 Charging: This is the most basic charging option and requires a standard 120-volt electrical 
outlet. Level 1 charging delivers approximately 2 to 5 miles of range per hour of charging time. 

2. Level 2 Charging: This charging option requires a dedicated 240-volt electrical circuit and a 
specialized charging station. Level 2 charging provides faster charging 
speeds than Level 1, delivering approximately 10 to 60 miles of range per hour of charging time. 

3. DC Fast Charging: Also known as Level 3 charging, DC fast charging delivers high- powered 
electricity directly to the vehicle's battery, allowing for rapid charging times of 30 minutes or less. DC fast 
charging requires specialized charging equipment and is typically only available at public charging stations. 
Proposed system: 
Wireless charging technology uses electromagnetic fields to transfer energy between a charging pad and a 
receiver coil in the vehicle. This method eliminates the need for cables and connectors and provides a 
convenient charging option for electric vehicles. 
The proposed system uses wireless charging technology, which are implemented in parking slots (Malls, 
Cinemas, Parks, Hospitals etc.,). The system is similar to weigh bridge- whenever the EV needed to charged 
stands above the wireless pad. Here the need for manual work is eliminated. 
The parking slots can be efficiently used for both parking and charging. The owner of the area can collect the 
bill amount for charging. 
Methodology: 
Wireless charging: 
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The methodology of wireless charging involves the transfer of energy from a power source to an electric vehicle 
without the use of cables or plugs. This is accomplished through the use of an inductive charging system, which 
consists of two main components: a charging pad and a receiver coil. 
The charging pad is typically connected to an electrical source and generates an alternating magnetic field. This 
magnetic field induces a current in the receiver coil, which is located on the underside of the electric vehicle. The 
current generated in the receiver coil is then used to charge the vehicle's battery. 
The process of wireless charging involves the following steps: 
 
The electric vehicle is parked over the charging pad, which is usually installed on the ground or embedded in a 
parking spot. 

1. The receiver coil on the underside of the vehicle is positioned over the charging pad. 
2. The charging pad generates an alternating magnetic field, which induces a current in the receiver 

coil. 
3. The current generated in the receiver coil is used to charge the vehicle's battery. 
4. Once the battery is fully charged, the charging process is automatically stopped. 

To ensure the safe and efficient operation of the wireless charging system, several factors must be taken into 
account, including the alignment of the receiver coil with the charging pad, the distance between the two 
components, and the power output of the charging pad. Additionally, a battery management system may be used 
to monitor the charging process and optimize the health and longevity of the vehicle's battery. 
Battery Management System: 
We have used lithium ion battery same as original batteries used in EV. This batteries will be made of individual 
lithium cells connected in series/parallel ( in our project we have connected two lithium cells 3.7v each in series so 
total 7.4v system for running EV).When more than one lithium cell is used battery management is needed. BMS 
is like a brain of Lithium battery pack. It protects the Lithium battery pack from overcharging, over-discharging, 
and over-drain, which results in a good backup and healthy battery life. It also protects the Battery pack from 
explosion, fire, and damage. A voltage sensor is used to verify the charging status. 
IOT based vehicle control: 
NodeMCU is an open-source development board designed for the Internet of Things (IOT) applications. It is 
based on the ESP8266 WiFi module. The NodeMCU board is equipped with a USB-to-serial converter, which 
allows for easy programming and debugging. 
The NodeMCU board has a small form factor and is equipped with a variety of I/O pins, including digital inputs 
and outputs, analog inputs, and I2C and SPI communication interfaces. This makes it a versatile platform for a 
wide range of IOT applications. 
The working of NodeMCU involves several steps. First, the board needs to be powered up either through a USB 
connection or an external power source. Once powered up, the NodeMCU board can be programmed using the Lua 
scripting language or the Arduino Integrated Development Environment (IDE). 
We have programmed using Arduino IDE. Once the code is uploaded to the NodeMCU board, it can be executed 
to control the board's various I/O pins, read sensor data, communicate with other devices over WiFi, and perform 
a wide range of other functions depending on the application. 
Block Diagram: 
Vehicle block:
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II.HARDWARE SPECIFICATIONS: 
A) Lithium ion battery: 

 
The rechargeable lithium-ion battery is made of one or more power-generating compartments called cells. Each 
cell has essentially three components. - positive electrode, negative electrode   and   electrolyte.   A    positive 
electrode connects to the battery's positive or + terminal. A negative electrode connects to the negative or − 
terminal. And a chemical called an electrolyte in between them. The positive electrode is typically made 
from a chemical compound called   lithium-cobalt   oxide (LiCoO2) or lithium iron phosphate (LiFePO4). The 
negative electrode is generally made from carbon (graphite). The electrolyte varies from one type of battery to 
another. 
The electrolyte carries positively charged lithium ions from the anode to the cathode. The movement of the 
lithium ions creates free electrons in the anode which creates a charge at the positive current collector. The 
electrical current then flows from the current collector through a device being powered (cell phone, computer, 
etc.) to the negative current collector. The separator blocks the flow of electrons inside the battery. 
 

B) Wireless Coil: 
 
Transmitter: 
 
The AC source voltage supplies the ac voltage at input of the coil. But before directly applying it to the coil a 
high frequency transformation is performed by which the frequency gets increased from 50Hz to several kHz. 
This is effectively done in order to achieve long distance and to reduce the power consumption. This frequency 
transformation is done by using switching devices by which alternately the devices can be made to generate the 
 

                                                                            Fig: Transmitter Section 
pulses and given as input to transmitting inductor (primary coil) & the voltage flow through this coil is in the 
form of electromagnetic waves which is then  transmitted towards receiving  inductor(secondary coil). 
Receiver: 
                                                                             Fig: Receiver Section 

 
The receiving inductor (secondary coil) is used to receive the electromagnetic waves which produce the voltage 
inside the coil which is in AC form. This voltage passed through rectifier & filter circuitry which converts the 
AC voltage in DC form & removes the unwanted contents using filter. This circuit used to provide smooth DC 
voltage. The received voltage may be in unregulated form which must be regulated using Voltage regulator so at 
the output we get regulated DC voltage. This regulated voltage is then given to the load which drives it. 
  Node MCU 
NodeMCU is an open-source Lua based firmware and development board specially targeted for IoT based 
Applications. It includes firmware that runs on the ESP8266 Wi-Fi SoC from Espressif Systems, and hardware 
which is based on the ESP- 12 module. 
The ESP8266 is the name of a micro controller designed by Espressif Systems. The ESP8266 itself is a self-
contained Wi-Fi networking solution offering as a bridge from existing micro controller to WiFi and is also 
capable of running self- contained applications. This module comes with a built in USB connector and a rich 
assortment of pin-outs. With a micro USB cable, you can connect NodeMCU devkit to your laptop and flash it 
without any trouble, just like Arduino. It is also immediately breadboard friendly. 
IR PROXIMITY SENSOR 
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A  proximity sensor  often emits an electromagnetic field or a beam of electromagnetic radiation and looks for 
changes in the field or return signal. The object being sensed is often referred to as the proximity sensor's target. 
Proximity sensors can have a high reliability and long functional life because of the absence of mechanical 
parts and lack of physical contact between sensor and the sensed object. 
  Software Arduino IDE 
The Arduino IDE is a popular open-source software that allows you to write and upload code to 
microcontrollers, including the ESP8266. 
 
To use the Arduino IDE for programming ESP8266, you need to follow these steps: 
 

 Install the Arduino IDE software on your computer. 
 Open the Arduino IDE software and go to "File" -> "Preferences". 
 In the "Additional Boards Manager URLs" field, add the following URL: 

"http://arduino.esp8266.com/stable/packag e_esp8266com_index.json" (without quotes). 
 Go to "Tools" -> "Board" -> "Boards Manager". 
 In the search field, type "esp8266" and select "esp8266 by ESP8266 Community". 
 Click on "Install". 
 After installation, go to "Tools" -> "Board" and select your ESP8266 board. 
 Connect your ESP8266 board to your computer using a USB cable. 
 Go to "Tools" -> "Port" and select the correct port for your board. 
 You can now write your code in the Arduino IDE and upload it to the ESP8266 board by clicking on 

the "Upload" button. 
 

III.RESULT: 

 
IV.CONCLUSION 

 
In this project, we implemented wireless energy transfer systems based on resonant inductive coupling with 
application to the charging of electric vehicles. In this work we also analyzed the implications of metal plates, 
ferrites and ground adjacent to the energy transfer system. The main outcome is presented together with what 
should be focused on in future studies. A wireless energy transfer system based on two inductively coupled 
resonant circuits separated by an air gap. It is showed that the coupled wireless energy transfer system has two 
resonance peaks and that the separation of these peaks increase with increasing coupling coefficient. To avoid the 
self-resonance of the coils, the length of the coil wire such that the self-resonance frequency appears at much 
higher frequencies than the frequency of operation is limited. Metal plates above the secondary coil can 
efficiently shield the surrounding from magnetic fields. However, the magnetic fields induce eddy currents in 
the metal plates, which decrease the coupling coefficient and increase the resistive losses. Ferrites, a material 
with very low eddy currents and high permeability, is placed on both the primary (transmitter) and secondary 
side(receiver) and it efficiently cancel the negative effects of the shielding plates and improve the coupling 
coefficient. Proper alignment and positioning of the coil is achieved in this project. A miniature model 
demonstration with power getting transferred from primary to secondary is achieved. The same concept could be 
adopted with scaling features in electric vehicles. 
 
FUTURE SCOPE: 
 
Wireless charging for moving electric vehicles (EVs) is a relatively new technology that is still in the 
development and testing phase. The basic idea is to use wireless charging technology to charge the batteries of 
electric vehicles as they move, eliminating the need for frequent stops to recharge. 
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Overall, while wireless charging for moving EVs is still a developing technology, it has the potential to be a game-
changer in the world of electric mobility, offering a more seamless and efficient charging experience for EV 
drivers. 
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